aboutsummaryrefslogtreecommitdiff
path: root/source/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'source/setup.py')
-rw-r--r--source/setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/source/setup.py b/source/setup.py
new file mode 100644
index 0000000..97b405d
--- /dev/null
+++ b/source/setup.py
@@ -0,0 +1,38 @@
+# Minimal distutils-based setup for Cryptech Alpha board software.
+#
+# Yes I know that the cool kids use setuptools these days, but that
+# drags in a lot of complex stuff which I don't think we really need
+# or even want here. Revisit if I turn out to be wrong about this.
+
+from distutils.core import setup
+
+try:
+ from cryptech_version import VERSION
+except ImportError:
+ VERSION = "0.0.0"
+
+setup(
+ name = "Cryptech Alpha",
+ version = VERSION,
+ description = "Software for Cryptech Alpha prototype HSM",
+ license = "BSD",
+ url = "https://cryptech.is/",
+
+ py_modules = [ "cryptech.libhal",
+ ],
+
+ packages = [ "cryptech.py11",
+ ],
+
+ package_dir = { "cryptech" : "sw/libhal/cryptech",
+ "cryptech.py11" : "sw/pkcs11/cryptech/py11",
+ },
+
+ scripts = [ "sw/libhal/cryptech_backup",
+ "sw/libhal/cryptech_console",
+ "sw/libhal/cryptech_muxd",
+ "sw/stm32/projects/hsm/cryptech_miniterm",
+ "sw/stm32/projects/hsm/cryptech_probe",
+ "sw/stm32/projects/hsm/cryptech_upload",
+ ],
+)