aboutsummaryrefslogtreecommitdiff
path: root/source/debian/rules
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2016-08-10 21:38:41 -0400
committerRob Austein <sra@hactrn.net>2016-08-10 21:39:21 -0400
commitbae21c7bc9053fa3fd5020c8a47d058b55d32380 (patch)
tree9f573fa02b6a7bd1bb570b33082cc2fb5c20a7d0 /source/debian/rules
parent39f7549c27cdfc5eb2f0456841d9427b55ea47c3 (diff)
Whole bunch of improvements to Debian packaging from Ondrej Sury (thanks!).
Diffstat (limited to 'source/debian/rules')
-rwxr-xr-xsource/debian/rules19
1 files changed, 18 insertions, 1 deletions
diff --git a/source/debian/rules b/source/debian/rules
index 2d33f6a..88d6c5a 100755
--- a/source/debian/rules
+++ b/source/debian/rules
@@ -1,4 +1,21 @@
#!/usr/bin/make -f
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+# DH_VERBOSE = 1
+
+# see FEATURE AREAS in dpkg-buildflags(1)
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all,-pie
+
+# see ENVIRONMENT in dpkg-buildflags(1)
+# package maintainers to append CFLAGS
+export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic -fno-omit-frame-pointer
+# package maintainers to append LDFLAGS
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+
+# see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/default.mk
+
%:
- dh $@
+ dh $@ --with python2