aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Austein <sra@hactrn.net>2015-05-20 16:57:33 -0400
committerRob Austein <sra@hactrn.net>2015-05-20 16:57:33 -0400
commitfa13a8485ce07aecfbfa481baccfc33565f0be0d (patch)
tree48d7da997e617fbbcb22bf86f96a3a43ca7049ce /configure.ac
parent93941c6393ec3454c64528e537534284a81b04ac (diff)
Add csprng and hash modules. Add real error codes instead of magic
numbers, and propegate error codes up from lower layers. Whack C++-isms, add parenthesese to a lot of macro expressions for evaluation safety, other minor cleanup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 5 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 43db468..07cd236 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,23 +17,13 @@ AC_ARG_VAR([CC], [C compiler command])
AC_ARG_VAR([CFLAGS], [C compiler flags])
AC_ARG_VAR([LDFLAGS], [Linker flags])
-AS_CASE($FPGA_BUS,
- [""],[FPGA_BUS=EIM],
- [EIM|I2C],[],
+AS_CASE($FPGA_BUS, [""],[FPGA_BUS=EIM], [EIM|I2C],[],
[AC_MSG_ERROR([Invalid setting of FPGA_BUS, must be "EIM" or "I2C"])])
-
-AS_CASE($CC,
- [""],[CC="cc"],
- [])
-
-AS_CASE($CFLAGS,
- [""],[CFLAGS="-g -Wall -fPIC"],
- [])
-
-AS_CASE($LDFLAGS,
- [""],[LDFLAGS="-g"],
- [])
+AS_CASE($CC, [""],[CC="cc"], [])
+AS_CASE($CFLAGS, [""],[CFLAGS="-g -Wall -fPIC"], [])
+AS_CASE($LDFLAGS, [""],[LDFLAGS="-g"], [])
+
AC_MSG_NOTICE([FPGA bus: $FPGA_BUS])
AC_MSG_NOTICE([C compiler: $CC])
AC_MSG_NOTICE([C compiler flags: $CFLAGS])